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Chapter 1 - Introduction 

About Navicat Data Modeler 

Navicat Data Modeler is a powerful and easy-to-use GUI tool for creating and manipulating database models. It 

enables users to design database structures, generate data dictionaries, reverse engineer, forward engineer, compare 

models, generate SQL/script files and print diagrams to files, etc. 

Navicat Data Modeler is available on three platforms - Microsoft Windows, macOS and Linux. Here are some highlights 

of Navicat Data Modeler: 

¶ Create and manipulate conceptual/logical/physical models. 

¶ Support various database systems: MySQL, MariaDB, Oracle, PostgreSQL, SQLite, SQL Server and MongoDB 

(including cloud databases like Amazon RDS, Amazon Redshift, Alibaba Cloud, Microsoft Azure). 

¶ Reverse engineer databases/schemas to a model. 

¶ Forward engineer a physical model to a SQL/Script file or a database/schema. 

¶ Compare two model workspaces. 

¶ Create and edit table structures directly. 

¶ Generate data dictionaries from models. 

¶ Support Navicat Cloud and Navicat On-Prem Server. 

For details, visit our website: https://www.navicat.com 

System Requirements 

Windows 

¶ Microsoft Windows 7, Windows 8, Windows 8.1, Windows 10, Windows 11, Server 2012, Server 2016, Server 

2019, Server 2022 

macOS 

¶ macOS 11 Big Sur, macOS 12 Monterey, macOS 13 Ventura, macOS 14 Sonoma, macOS 15 Sequoia 

Linux 

x86_64 

¶ Debian 10, Debian 11, Debian 12, Ubuntu 20.04, Ubuntu 22.04, Ubuntu 24.04, Fedora 38, Fedora 39, Fedora 

40, Linux Mint 20, Linux Mint 21, Deepin 20, KylinOS Desktop 10 

aarch64 

https://www.navicat.com/
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¶ Debian 11, Debian 12, Ubuntu 22.04, Ubuntu 24.04, Fedora 38, Fedora 39, Fedora 40, Linux Mint 20, Linux Mint 

21, KylinOS Desktop 10 

Supported Databases 

¶ MySQL 3.23 or above 

¶ PostgreSQL 7.3 or above 

¶ Oracle 8i or above 

¶ SQLite 3 

¶ SQL Server 2000 or above and SQL Azure 

¶ MariaDB 5.1 or above 

¶ MongoDB 2.6 or above 

¶ Redshift 1.0 

¶ OceanBase Community 3.1 or above and Enterprise 3.2 or above (Enterprise Oracle Mode is not available in 

macOS Edition) 

Installation 

We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation. 

Installation for Download Version 

1. Download Navicat Data Modeler macOS version. 

2. Open the .dmg file. 

3. Drag Navicat Data Modeler to your Applications folder to install. 

Installation for CD Version 

1. Load the Navicat Data Modeler CD Installation disk into the CD-ROM drive. 

2. Open the .dmg file. 

3. Drag Navicat Data Modeler to your Applications folder to install. 

Registration 

When the trial period is finished, Navicat Data Modeler requires a license key or a subscription plan to continue using 

the features. 
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Note: Perpetual License and Subscription Plan cannot be used at the same Navicat Data Modeler. Before changing 

the registration method, you need to deactivate the license key or sign out your Navicat ID. 

Perpetual License 

If you have purchased a perpetual license, you will receive a license key for activating Navicat Data Modeler. 

In the Perpetual License section, paste your license key (16 digits) and click the Activate button. Navicat Data 

Modeler contacts our licensing server to activate the license key. If the activation process is successful, the license key 

details are displayed. 

Manual Activation 

Manual activation is available when your computer does not have an internet connection. You will need another 

computer with an internet connection to complete this activation process. 

1. If the online activation is failed, click Manual Activation. 

2. Copy the Request Code in the Copy the Request Code Here: box. 

3. Open web browser on a computer with an internet connection and then go to 

https://customer.navicat.com/manual_activate.php. 

4. Paste/Enter the Request Code into the left box. 

5. Click Get Activation Code. 

6. Copy the generated Activation Code in the right box. 

7. Go back to the computer where you are activating Navicat Data Modeler. 

8. Paste the Activation Code into the Paste the Activation Code Here: box. 

9. Click Activate. 

Subscription Plan 

If you have subscribed a plan, you can sign in your Navicat ID to use Navicat Data Modeler during the subscription 

term. 

Note: Navicat ID is the Email address that you used to subscribe the plan. 

In the Subscription section, provide your Navicat ID and Password. After signed in, the subscription plan details are 

displayed. 

Navicat Data Modeler contacts our licensing server once per hour to auto reload the plan by default. If you have 

updated your plan in the portal site, you can use the Reload Plan button to force reloading the new plan. 
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Note: Each Navicat ID can connect to only one Navicat Data Modeler. If you sign in your Navicat ID in another Navicat 

Data Modeler, you will be signed out from the current Navicat Data Modeler. 

Migration / Upgrade 

Migrate Navicat Data Modeler to a new computer 

1. In Navicat Data Modeler, choose Navicat Data Modeler -> Registration. 

2. [Perpetual License] Click Deactivate to online deactivate the license key. 

3. [Subscription Plan] Click Sign Out to sign out your Navicat ID. 

4. Uninstall Navicat Data Modeler from the existing computer. 

5. Re-install Navicat Data Modeler in the new computer. 

Upgrade Navicat Data Modeler 

If you want to upgrade an installed copy of Navicat Data Modeler to the latest release, please choose Navicat Data 

Modeler -> Check for Updates to start the Updater. It will automatically check your installed version. If there is a new 

version, simply follow the steps in the Updater to upgrade your Navicat Data Modeler. It will replace your previous 

Navicat Data Modeler and your current settings will remain unchanged. 

Or, you can submit your registered email address on the Customer Center to download the latest version installer. 

End-User License Agreement 

Note: For the License Agreement of Navicat Cloud service, please click here. 

IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT 

BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN 

ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE 

INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE 

AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE 

SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME 

BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS, 

THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE. 

THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD. 

HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN. 

1. Definitions 

a. "Non-commercial Version" means a version of the Software, so identified, for use by i) the individual who is a 

natural person and not a corporation, company, partnership or association or other entity or organization (ii) the 

individual who is a student, faculty or staff member at an educational institution, and (iii) staff of a non-profit 

https://customer.navicat.com/
https://legal.navicat.com/navicatcloud/NavicatCloudLicenseAgreement.rtf
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organization or charity organization only. For purposes of this definition, "educational institution" means a 

public or private school, college, university and other post secondary educational establishment. A non-profit 

organization is an organization whose primary objective is to support an issue or matter of private interest or 

public concern for non-commercial purposes. 

b. "Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review and 

evaluate the Software, only. 

c. "PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any. 

d. "Software" means only the PremiumSoft software program(s) and third party software programs, in each case, 

supplied by PremiumSoft herewith, and corresponding documentation, associated media, printed materials, 

and online or electronic documentation. 

e. "Unregistered version", "Trial version" or "Demo version" means an unregistered copy of the SOFTWARE 

("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation purposes for a period of 

fourteen (14) days following the initial installation of the UNREGISTERED SOFTWARE. At the end of the trial 

period ("TRIAL PERIOD"), the USER must either register the SOFTWARE or remove it from his system. The 

UNREGISTERED SOFTWARE may be freely copied and distributed to other users for their evaluation. 

f. "Navicat Data Modeler Lite" means a free-to-use version of the Software with limited features, identified as 

"Lite". 

2. License Grants 

The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA: 

a. Subject to Section 2(b), you may install and use the Software on a single computer; OR install and store the 

Software on a storage device, such as a network server, used only to install the Software on your other 

computers over an internal network, provided you have a license for each separate computer on which the 

Software is installed and run. Except as otherwise provided in Section 2(b), a license for the Software may not 

be shared, installed or used concurrently on different computers. 

b. In addition to the single copy of the Software permitted in Section 2(a), the primary user of the computer on 

which the Software is installed may make a second copy of the Software and install it on either a portable 

computer or a computer located at his or her home for his or her exclusive use, provided that: 

A. the second copy of the Software on the portable or home computer (i) is not used at the same time as 

the copy of the Software on the primary computer and (ii) is used by the primary user solely as allowed 

for such version or edition (such as for educational use only), 

B. the second copy of the Software is not installed or used after the time such user is no longer the 

primary user of the primary computer on which the Software is installed. 

c. In the event the Software is distributed along with other PremiumSoft software products as part of a suite of 

products (collectively, the "Studio"), the license of the Studio is licensed as a single product and none of the 
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products in the Studio, including the Software, may be separated for installation or use on more than one 

computer. 

d. You may make one copy of the Software in machine-readable form solely for backup purposes. You must 

reproduce on any such copy all copyright notices and any other proprietary legends on the original copy of the 

Software. You may not sell or transfer any copy of the Software made for backup purposes. 

e. You agree that PremiumSoft may audit your use of the Software for compliance with these terms at any time, 

upon reasonable notice. In the event that such audit reveals any use of the Software by you other than in full 

compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all reasonable expenses 

related to such audit in addition to any other liabilities you may incur as a result of such non-compliance. 

f. Your license rights under this EULA are non-exclusive. 

3. License Restrictions 

a. Other than as set forth in Section 2, you may not make or distribute copies of the Software, or electronically 

transfer the Software from one computer to another or over a network. 

b. You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer, 

disassemble, or otherwise reduce the Software to a human-perceivable form. 

c. Unless otherwise provided herein, you may not rent, lease, or sublicense the Software. 

d. Other than with respect to a Trial / Demo Version, Lite Version or a Not For Resale Version of the Software, 

you may permanently transfer all of your rights under this EULA only as part of a sale or transfer, provided you 

retain no copies, you transfer all of the Software (including all component parts, the media and printed 

materials, any upgrades, this EULA, the serial numbers, and, if applicable, all other software products provided 

together with the Software), and the recipient agrees to the terms of this EULA. If the Software is an upgrade, 

any transfer must include all prior versions of the Software from which you are upgrading. If the copy of the 

Software is licensed as part of the whole Studio (as defined above), the Software shall be transferred only with 

and as part of the sale or transfer of the whole Studio, and not separately. You may retain no copies of the 

Software. You may not sell or transfer any Trial / Demo Version, Lite Version or Not For Resale Version of the 

Software. 

e. Unless otherwise provided herein, you may not modify the Software or create derivative works based upon the 

Software. 

f. Non-commercial Versions of the Software may not be used for, or distributed to any party for, any commercial 

purpose. 

g. Unless otherwise provided herein, you shall not 

A. in the aggregate, install or use more than one copy of the Trial / Demo Version of the Software, 

B. download the Trial / Demo Version of the Software under more than one username, 
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C. alter the contents of a hard drive or computer system to enable the use of the Trial / Demo Version of 

the Software for an aggregate period in excess of the trial period for one license to such Trial / Demo 

Version, 

D. disclose the results of software performance benchmarks obtained using the Trial / Demo Version or 

Lite Version to any third party without PremiumSoft prior written consent, or 

E. use the Trial / Demo Version of the Software for a purpose other than the sole purpose of determining 

whether to purchase a license to a commercial or education version of the software; provided, however, 

notwithstanding the foregoing, you are strictly prohibited from installing or using the Trial / Demo 

Version or Lite Version of the Software for any commercial training purpose. 

h. For Navicat Data Modeler Lite: For avoidance of doubt, Navicat Data Modeler Lite is licensed, not sold. Under 

this EULA, PremiumSoft grants you the right to 1) download [one copy] of the software, and 2) install and run 

[one instance] of the software on your [one device], whether physical or virtual with an internal storage device 

capable of running the software, so long as you comply with all the terms of this EULA. 

If you were in possession of multiple software versions, you may only install and run [one] of those versions at 

a time. If you use the software on more than one physical or virtual device, you must obtain a separate license 

for each instance. 

[Commercial Use] 

The number of users at any time within a business, whether incorporated or not, shall not exceed [five persons]. 

To use the software on more than one device, you are required to obtain a dedicated license and you may 

allow up to [five other devices] to access the software installed on the licensed device for commercial use. 

[Non-Commercial Use] 

Users qualified for PremiumSoft's Non-Commercial Licensing Program, subject to the conditions of the 

program as detailed in Navicat Non-Commercial Licensing Program 

(www.navicat.com/en/store/non-commercial), are granted the right to download, install, run, and use the 

software. 

i. You may only use the Not for Resale Version of the Software to review and evaluate the Software. 

j. You may receive the Software in more than one medium but you shall only install or use one medium. 

Regardless of the number of media you receive, you may use only the medium that is appropriate for the 

server or computer on which the Software is to be installed. 

k. You may receive the Software in more than one platform but you shall only install or use one platform. 

l. You shall not use the Software to develop any application having the same primary function as the Software. 

m. In the event that you fail to comply with this EULA, PremiumSoft may terminate the license and you must 

destroy all copies of the Software (with all other rights of both parties and all other provisions of this EULA 

surviving any such termination). 

n. This program may include Oracle Instant Client (OCI). You agree that you shall 

a. not use of the Oracle Instant Client to the business operations; 

https://www.navicat.com/en/store/non-commercial
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b. not assign, give, or transfer the Oracle Instant Client or an interest in them to another individual or 

entity; 

a. make the Programs available in any manner to any third party for use in the third party's 

business operations; and 

b. title to the Programs from passing to the end user or any other party; 

c. not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the 

Programs except for a sufficient number of copies of each Program for your licensed use and one copy 

of each Program media; 

d. discontinue use and destroy or return to all copies of the Oracle Instant Client and documentation after 

termination of the Agreement; 

e. not publish any results of benchmark tests run on the Programs; 

f. comply fully with all relevant export laws and regulations of the United States and other applicable 

export and import laws to assure that neither the Oracle Instant Client, nor any direct product thereof, 

are exported, directly or indirectly, in violation of applicable laws; 

g. allow PremiumSoft to audit your use of the Oracle Instant Client; 

4. Upgrades 

If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license 

exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your 

earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person or 

entity unless such transfer is pursuant to Section 3. 

5. Ownership 

The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights, title 

and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent work and 

as an underlying work serving as a basis for any application you may develop), and all copies thereof. All rights not 

specifically granted in this EULA, including Federal and International Copyrights, are reserved by PremiumSoft and its 

suppliers. 

6. LIMITED WARRANTY AND DISCLAIMER 

a. Except with respect to Trial / Demo Version, Lite Version and Not For Resale Version of the Software, 

PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as evidenced by a copy of 

your receipt): the physical media on which the Software is furnished will be free from defects in materials and 

workmanship under normal use. The Software is provided "as is". PremiumSoft makes no warranties, express 

or implied, arising from course of dealing or usage of trade, or statutory, as to any matter whatsoever. 
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b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version, Lite 

version and the Not for Resale version of the Software. Trial / Demo version, Lite version and the Not for 

Resale version of the Software are provided "as is". 

c. Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo version, 

Lite version and Not for Resale version, PremiumSoft and its suppliers disclaim all other warranties and 

representations, whether express, implied, or otherwise, including the warranties of merchantability or fitness 

for a particular purpose. Also, there is no warranty of non-infringement and title or quiet enjoyment. 

PremiumSoft does not warrant that the Software is error-free or will operate without interruption. The Software 

is not designed, intended or licensed for use in hazardous environments requiring fail-safe controls, including 

without limitation, the design, construction, maintenance or operation of nuclear facilities, aircraft navigation or 

communication systems, air traffic control, and life support or weapons systems. PremiumSoft specifically 

disclaims any express or implied warranty of fitness for such purposes. 

d. If applicable law requires any warranties with respect to the Software, all such warranties are limited in duration 

to thirty (30) days from the date of delivery. 

e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or employees 

shall create a warranty or in any way increase the scope of ANY warranty PROVIDED HEREIN. 

7. LIMITATION OF LIABILITY 

(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental, 

punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or access 

data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability to use, the 

Software and based on any theory of liability including breach of contract, breach of warranty, tort (including 

negligence), product liability or otherwise, even if PremiumSoft or its representatives have been advised of the 

possibility of such damages. 

8. Third Party Software 

The Software may contain third party software which requires notices and/or additional terms and conditions. By 

accepting this EULA, you are also accepting the additional terms and conditions of the third party software. 

9. General 

No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA. 

This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and 

supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that any 

varying or additional terms contained in any purchase order or other written notification or document issued by you in 

relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to exercise any of 

its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those rights or of the 

breach. 
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If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision will 

be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full force and 

Effect. 

10. Basis of Bargain 

The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of the 

agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an economic 

basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the benefit of 

PremiumSoft's licensors. 

11. Term 

By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA. 

This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to 

comply with any term of this License. 

"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or statutory, 

as to any matter whatsoever. In particular, any and all warranties or merchantability, fitness for a particular purpose or 

non-infringement of third party rights are expressly excluded. 

12. License Termination 

Without prejudice to any other rights, PremiumSoft may terminate this EULA if you fail to comply with the terms and 

conditions of this EULA. In such event, you must destroy all copies of the software and all of its component parts. 

13. Governing Law 

This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive jurisdiction 

and venue sitting in Hong Kong to resolve any disputes arising under this EULA. 

Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If you 

desire to contact the Licensor for any other reason, please contact support@navicat.com. 

PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of PremiumSoft 

CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names, product names and 

logos may be the trademarks or registered trademarks of their respective owners. You may not remove or alter any 

trademark, trade names, product names, logo, copyright or other proprietary notices, legends, symbols or labels in the 

Software. This EULA does not authorize you to use PremiumSoft or its licensors names or any of their respective 

trademarks. 
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Chapter 2 - User Interface 

Main Window 

 

 Navigation Pane 

The Navigation pane allows you to create new models, open local model files, recently opened model files, or model files 

in Navicat Cloud / On-Prem Server. If the Navigation pane is hidden, choose View -> Show Navigation Pane from the 

menu bar. 

 Content Pane 

The Content pane contains the models that are in the selected section of the Navigation pane. Use the  Detail or  

Icon buttons to change the view. 

 Information Pane 

The  General tab shows the general information of the model or the selected item. 

The  Project tab shows the project members and the project activities done by the members. Click + to add 

members to the project. 

If the Information pane is hidden, choose View -> Show Information Pane from the menu bar. 
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Chapter 3 - Collaboration 

About Collaboration 

Navicat Data Modeler allows you to synchronize connection settings, model workspaces and virtual group information 

from Navicat Data Modeler, other Navicat family members, different machines and different platforms. You can use 

Navicat Cloud to host the files. Or, if you have installed our another product, Navicat On-Prem Server, in your 

environment, you can hosts everything in-house. 

Our collaboration feature allows you to give your teammates access to your projects when they log into their accounts. 

That way, you and your teammates can work on the same project without revealing your username and password. You 

can even choose to restrict the type of access your teammates have to your project. 

Manage Cloud 

Navicat Cloud 

Navicat Cloud is a cloud service provided by PremiumSoft for synchronizing connection settings, queries, aggregation 

pipelines, snippets, model workspaces, BI workspaces and virtual group information. 

Navicat Cloud could not connect and access your databases. By which it means, it could only store your connection 

settings, queries, aggregation pipelines, snippets, model workspaces, BI workspaces and virtual group information; your 

database passwords and data (e.g. tables, views, etc) will not be stored to Navicat Cloud. 

Note: You can only sign in to one Navicat Cloud account in the software. PremiumSoft will keep all synchronized files 

strictly confidential, and all employees are prohibited from viewing/accessing content of files you may store in your 

Navicat Cloud account. 

Create Navicat Cloud Account 

1. In the menu bar, choose Navicat Data Modeler -> Manage Cloud. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click Create Navicat ID. 

4. Enter the required information and click Sign Up. A verification email will send to your email address. 

5. Click the link in the email to verify the new account. 

Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center. 

Sign In Navicat Cloud 

1. In the menu bar, choose Navicat Data Modeler -> Manage Cloud. 

2. In the Manage Cloud window, select Navicat Cloud. 
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3. Enter your Navicat ID and Password. 

4. Click Sign In. 

5. If you enabled two-step verification in Navicat Cloud Portal, a code will be sent to your phone via your mobile 

app. Enter the received code to sign in. 

Sign Out Navicat Cloud 

1. Close all models in Navicat Cloud. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select Navicat Cloud. 

4. Click Sign Out. 

View Usage 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Your usage and current plan will be shown. 

Change Your Picture 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click your avatar. 

4. Choose an image file. 

Manage Your Account 

You can change your password, enable Two-Step Verification, upgrade Cloud Plan, etc in Navicat Cloud Portal. 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click Manage Account. 

4. A web browser will automatically open up to Navicat Cloud Portal. 

https://cloud.navicat.com/
https://cloud.navicat.com/
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On-Prem Server 

Navicat On-Prem Server is an on-premise solution that provides you with the option to host a cloud environment for 

storing Navicat objects (connection settings, queries, aggregation pipelines, snippets, model workspaces, BI 

workspaces and virtual group information) internally at your location. 

Before you can add an On-Prem Server, you must first set up Navicat On-Prem Server in your environment. 

Add New On-Prem Server 

1. In the menu bar, choose Navicat Data Modeler -> Manage Cloud. 

2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server. 

3. Enter your On-Prem Server login information. 

Option Description 

Host The host name or IP address of your On-Prem Server. 

Port The port number of your On-Prem Server. 

Verify Server Certificate Enable this option to verify the server certificates. 

Enable Push 

Synchronization 

Navicat Data Modeler receives a silent push notification whenever its 

files stored in your On-Prem Server changes. 

4. Click OK. 

Add New On-Prem Server with URI 

1. In the menu bar, choose Navicat Data Modeler -> Manage Cloud. 

2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server with URI. 

3. Paste your On-Prem Server URI. 

4. Click OK. 

Note: The URI can be copied from your On-Prem Server portal site. 

Sign In On-Prem Server 

1. In the menu bar, choose Navicat Data Modeler -> Manage Cloud. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Enter your Username and Password. 

4. Click Sign In. 

5. If you enabled two-step verification, a code will be sent to you via the verification method you have selected. 

Enter the received code to sign in. 
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Sign Out On-Prem Server 

1. Close all models in your On-Prem Server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

Edit On-Prem Server 

1. Close all models in your On-Prem Server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Control-click your server and select Edit On-Prem Server. 

6. Edit the On-Prem Server information. 

7. Sign in your server. 

Rename On-Prem Server 

1. Close all models in your On-Prem Server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Control-click your server and select Rename. 

6. Enter the name to describe your On-Prem Server. 

7. Sign in your server. 

Remove On-Prem Server 

1. Close all models in your On-Prem Server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 
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5. Control-click your server and select Remove On-Prem Server. 

6. Click Delete. 

View Usage 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Your usage will be shown. 

Change Your Picture 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Click your avatar. 

4. Choose an image file. 

Manage Your Account 

You can change your password, enable Two-Step Verification, etc in your On-Prem Server web portal. 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Click Manage Account. 

4. A web browser will automatically open up to your On-Prem Server web portal. 

Push Synchronization 

Push Synchronization enables Navicat Data Modeler to receive a silent push notification whenever the files stored in 

Navicat Cloud or On-Prem Server changes. 

Enable Push Synchronization 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, control-click Navicat Cloud or your On-Prem Server. 

3. Turn on Enable Push Synchronization. 

Disable Push Synchronization 

1. At the top right, click your avatar. 
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2. In the Manage Cloud window, control-click Navicat Cloud or your On-Prem Server. 

3. Turn off Enable Push Synchronization. 

Cache and Local Copies 

When you logged into Navicat Cloud or your On-Prem Server, Navicat Data Modeler saves the cloud object files and 

some information in the local computer. The cache and local copies use to make sure your changes are saved in the 

cloud. 

Clear Cache and Local Copies 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud or your On-Prem Server. 

3. Click Sign Out. 

4. Control-click Navicat Cloud or your On-Prem Server and select Clear Cache and Local Copies. 

5. Click Clear. 

Show In Finder 

1. In the main window, select Navicat Cloud or your On-Prem Server. 

2. Open your project. 

3. Control-click anywhere in the project and select Show In Finder. 

Projects 

Work With Projects 

A project is a way to structure and organize Navicat objects. You can put related objects in one project, and then share 

the project with other accounts for collaboration if necessary. 

Create New Projects 

1. In the main window, select Navicat Cloud or your On-Prem Server. 

2. Click + New Project. 

3. Enter the name of the new project. 

4. Click OK. 

Manage Existing Projects 

To rename a project 
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1. In the main window, control-click the project and select Rename. 

2. Enter a new project name. 

Note: Only the project owner and the members with the Can Manage & Edit right can rename the project. 

To delete a project 

1. In the main window, control-click the project and select Delete Project. 

2. Click Delete. 

Note: Only the project owner can delete the project. 

Note: Before you delete the project, you must remove all objects in the project. 

To quit a project 

1. In the main window, control-click the project and select Quit Project. 

2. Click Quit. 

Manage Members 

Add Members 

1. In the main window, control-click the project and select Manage Members. 

2. Click Add Members. 

3. [Navicat Cloud] Enter the member's Navicat ID and press ENTER. 

4. [On-Prem Server] Check the boxes of the users that you want to add. 

5. Select the member right. 

6. Click Add. 

Member Rights Privileges 

Can Manage & Edit Read Objects, Write Objects, Manage Members and Rename 

Projects 

Can Edit Read Objects and Write Objects 

Can View Read Objects 

Manage Existing Members 

To edit the right of a member 

1. In the main window, control-click the project and select Manage Members. 
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2. Use the drop-down list next to the member to change the right. 

3. Click Apply. 

To remove a member from a project 

1. In the main window, control-click the project and select Manage Members. 

2. Click the X icon next to the member. 

3. Click Apply. 
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Chapter 4 - Workspace 

About Workspace 

A workspace is the place that comprises models, diagrams and data dictionaries. You can create multiple models, 

diagrams and data dictionaries in a workspace. 

 

 Workspace Toolbar 

The Workspace Toolbar provides controls that you can use to create models, diagrams and data dictionaries. 

 Tab Bar 

The Tab Bar allows you to switch among the opened items. 

 Content Pane 

The Content pane shows all items in the workspace. To change the view, click the  Detail or  Icon button at the 

bottom of the window. 

Detail View displays additional information about each item. You can sort items in Detail View, click the column header 

by which you want to sort the items. 

Icon View displays your items as a grid of thumbnail images. You can filter the items by clicking a category (All, Model, 

Diagram, Data Dictionary) in this view. 

 Properties Pane 

The  General tab shows the general information of the workspace or the selected item. 

If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 
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Create Workspace 

Local Workspace File 

The essential steps to create a workspace are: 

1. In the main window, click  New Workspace. 

2. Create models, diagrams and data dictionaries. 

3. Choose File -> Save. 

4. Enter the file name and choose the save path. 

5. Click Save. 

Cloud Workspace File 

If you have logged into Navicat Cloud / On-Prem Server, you can store the workspace in a project. 

The essential steps to create a workspace are: 

1. In the main window, click  New Workspace. 

2. Create models, diagrams and data dictionaries. 

3. Choose File -> Save. 

4. Enter the workspace name and choose the project. 

5. Click Save. 
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Chapter 5 - Model 

About Model 

A model is a collection of database objects that can be effectively utilized within diagrams. These objects can be 

reused across various diagrams, thereby increasing efficiency and consistency in the design and presentation of 

database structures. 

 

 Model Pane 

The Model pane is the basic way to navigate with databases/schemas, tables, views, functions or entities. 

 Object Toolbar 

The Object Toolbar provides controls that you can use to manipulate the object. 

 Object Pane 

The Object pane shows the objects you created in the model. 

 Properties Pane 

The  General tab shows the general information of the selected object. 

The  DDL tab shows the DDL of the selected object. 

If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 

Create Model 

The essential steps to create a model are: 

1. In the Workspace window, click  New Model. 
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2. Enter the name of the model and select a model type, target database, and database version. 

3. Click OK. 

4. A tab will open for you to edit the model. 

Add Database / Schema 

When creating a new model, a database (named default) is automatically created and it is the default database. 

You can view all databases/schemas with their objects as tree structure on the Model pane. 

To create a new database 

1. On the Model pane, control-click the model name or database and select New Database. 

2. Enter the name of the database. 

3. Click OK. 

To create a new schema 

1. On the Model pane, control-click the database or schema and select New Schema. 

2. Enter the name of the schema. 

3. Click OK. 

Create Table 

The essential steps to create a table are: 

1. On the Model tab, select Tables in the Model pane. 

2. Click , or click the down arrow and choose the table type. 

3. Enter the name of the table. 

4. Click OK. 

5. A tab will open for you to edit the table. 

Create RDBMS View 

Create View 

The essential steps to create a view are: 

1. On the Model tab, select Views in the Model pane. 
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2. Click . 

3. Enter the name of the view. 

4. Click OK. 

5. A tab will open for you to edit the view. 

View Editor 

In SQL Editor tab, you can create and edit the SELECT statement SQL for a view. Navicat Data Modeler provides a 

wide range advanced features for editing the view definition, such as compelling code editing capabilities, smart 

code-completion, sql formatting, and more. 

Hint: SELECT statement will be automatically generated while you build in View Builder. 

Beautify SQL 

To format messy SQL code into a well-structured script, you can click the  button. To minify SQL code by removing 

spaces, tabs and newlines, control-click the editor and select Minify SQL. 

Code Completion 

Code completion feature in Navicat Data Modeler pops up a list of suggestions as you type your SQL statement in the 

editor. It assists you with statement completion and the available properties of database objects, for example 

databases, tables, fields, views etc with their appropriate icons and information. 

To invoke code completion, just simply press '.' for the available properties of database object currently in the scope. 

When the suggestion list appears, press TAB to insert the first item. You can also select the needed item using UPPER 

ARROW or DOWN ARROW and then press TAB or ENTER. 

 

In addition, code completion can be invoked by typing a character or pressing ESC on your keyboard for SQL 

keywords/database objects. 

If you select a snippet name from the list, the saved code will be inserted to the editor. 

Hint: Resize the suggestion list by dragging the lower right corner. 
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You can enable or disable the code completion feature in Settings. 

Clipboard Stack 

When you copy or cut some codes as usual in the editor, the copied content will also be added to Clipboard Stack. 

Clipboard Stack can store up to 10 items and use the last-in-first-out logic. To paste an item from Clipboard Stack, you 

can press COMMAND-SHIFT-V. Press COMMAND-SHIFT-V multiple times to cycle through Clipboard Stack. 

Code Folding 

Code folding feature enables you to collapse blocks of code such that only the first line of the block appears in the 

editor. 

A block of code that can be folded is indicated by an icon  to the left of the first line of the block. A vertical line 

extends from the icon to the bottom of the foldable code. In contrast, a folded block of code is indicated by an icon  

to left of the code block. You can fold the block by clicking  or expand it by clicking . 

 

Syntax Highlight 

Navicat Data Modeler uses syntax highlighting which depending on the database associated with the query. Different 

databases have different sets of reserved keywords. You can configure the associated colors for different text 

fragments in Settings. 

Brace Highlight 

Navicat Data Modeler supports to highlight the matching brace in the editor, i.e. () . 

Note: The cursor must be on a brace to show the highlight. 

 

Find and Replace 
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Find 

The Find bar is provided for quick searching for the text in the editor. Just simply choose Edit -> Find from the menu or 

press COMMAND-F, and then enter a search string. 

Incremental searching is used here. As you type, the matched text is found and highlighted instantly. This saves your 

time from typing the entire text. 

The search starts at the cursor's current position to the end of the file. 

To find the previous or next occurrence, just simply click  or . 

Replace 

To open the Replace bar, simply choose Edit -> Find -> Find and Replace from the menu bar or press 

OPTION-COMMAND-F. Then, enter the text you want to search and replace. 

Click the Replace button to replace the first occurrence. 

Click the Replace All button to replace all occurrences automatically. 

There are some additional options for Find and Replace, click : 

Option Description 

Regular Expression Search regular expressions. 

Match Case Enable case sensitive search. 

Whole Word Return the objects that match the entire word of the search string. 

Copy with Quotes 

To copy the SQL statement with quotes, just simply control-click the highlighted SQL. Then, select Copy with Quotes 

and choose the format. 

Zoom In/Zoom Out 

Navicat Data Modeler has the ability to zoom in or zoom out the SQL in the editor. 

Zoom In: [COMMAND-+] 

Zoom Out: [COMMAND--] 

Reset: [COMMAND-0] 

View Builder (Available only in Enterprise Edition) 

Navicat Data Modeler provides a useful tool called View Builder for building views visually. It allows you to create and 

edit views without knowledge of SQL. Even if you are familiar with SQL, the convenient and fluent graphical interface 

makes it easier to create relations and visualize the view. 
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In View Designer, click the  button to open the visual View Builder. 

All database objects are displayed on the left Object pane. Whereas on the middle pane, it is divided into two portions: 

the upper Diagram pane, and the lower Criteria pane. When building the view, you can view the auto-generated SQL 

on the right SQL pane. 

 

Add Objects to View 

The first step is to decide which tables and views you need to add to the view. 

To add tables and views to the view, use one of the following methods: 

¶ Drag them from the Object pane to the Diagram pane. 

¶ Double-click them on the Object pane. 

You can set aliases for tables, views and subqueries by double-clicking the object title on the Diagram pane and 

entering the name to use as an alias for the object name. 

After you have added objects to the diagram, you can use the FROM tab to adjust the view to your needs. 

¶ To change the object, click the object and select an identifier. 

¶ To add the table alias, click <Alias>. 
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You can control-click an object on the Diagram pane and select Remove, or simply press DELETE key to remove the 

selected object from the view. 

When you remove an object, View Builder automatically removes joins that involve that object. 

Choose Output Fields 

To include fields in the view, use one of the following methods: 

¶ Check the left checkbox of a field name you want to add to the view on the Diagram pane. 

¶ To include all the fields for an object, check the * checkbox on the Diagram pane. 

¶ To add all fields for all objects, click  on the SELECT tab and select All fields(*). 

The selected fields display on the SELECT tab. You can specify additional output field options. 

¶ Check the DISTINCT checkbox to force the view to return distinct results. 

¶ To add the field alias, click <Alias> and enter the name. 

¶ Click the identifier and select the Aggregate function. 

¶ Use the up arrow and down arrow buttons to change the order of fields. 

Set Field Association 

View Builder will automatically join the tables as per the foreign key relations. If you want to associate database objects 

manually, just select a field from an object and drag it to a field in another object. A connector line appears between the 

two objects to visually represent the relationship and the join type. 

There are two views to show the connector lines: Table Relation and Field Relation. The Field Relation view allows 

you to identify matching fields in two tables, while the Table Relation view displays the join relationship between the 

two tables. 

All joins are initially created as INNER JOIN by default. To change the association, click or double-click the connector 

line on the Diagram pane or click the JOIN keyword on the FROM tab, and then select a join type. If a join type is not 

listed, you can enter a customized one in the Custom textbox. 
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To remove a join, control-click the connector line and select Remove. 

To modify the join condition, control-click a connector line and select Edit Join, or click the condition on the FROM tab. 

 

The pop-up menu options of the FROM tab: 

Option Description 

Insert Add an identifier, an expression or a subquery. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the identifier, expression or subquery. 

Edit SQL Edit the subquery. 

Convert to Subquery Convert the condition to a subquery. 

Clear and Convert to 

USING Clause 

Remove the ON condition and convert it to USING clause. 

Clear and Convert to ON 

Clause 

Remove the USING condition and convert it to ON clause. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Set Filter Criteria 

When retrieving data, you may want to set up a filtering expression. To filter data returned by the view, control-click a 

field on the Diagram pane and select Add Field To -> WHERE and an operator. 
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The condition is added to the WHERE tab. You can edit the value there by clicking <Value>. If you want to add a 

condition with parentheses, click . You can change a logical operator (and/or) by clicking it. Use the up arrow and 

down arrow buttons to change the order of conditions. 

 

The pop-up menu options of the WHERE tab: 

Option Description 

Toggle Negator Reverse the meaning of the condition. 

Insert Add a condition. 

Insert Custom Add a custom condition. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the condition. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Group Resulting Data 

You can set the conditions for grouping records by control-clicking a field in the Diagram pane and selecting Add Field 

To -> GROUP BY -> Add Field. 

The condition is added to the GROUP BY tab. Use the up arrow and down arrow buttons to change the order of fields. 

On the HAVING tab, you can filter summarized data or grouped data. Select the identifiers, operators, aggregate or 

enter expressions to include in the condition. Use the up arrow and down arrow buttons to change the order of 

conditions. 

The pop-up menu options of the HAVING tab: 

Option Description 

Toggle Negator Reverse the meaning of the condition. 

Insert Add a condition. 

Insert Custom Add a custom condition. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the condition. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Sort Resulting Data 
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You can set the way of sorting records by control-clicking a field on the Diagram pane and selecting Add Field To -> 

ORDER BY -> ASC or DESC. The condition will be added to the ORDER BY tab. 

Limit Resulting Data 

On the LIMIT tab, you can limit your view results to those that fall within a specified range. 

Offset 

Specify the number of records to be skipped. It is optional. 

Limit 

Specify the number of records to be displayed. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Add Expressions/Subqueries 

You can add an expression or a subquery to further limit the view results. On the FROM tab, click  and select the 

Expression/Subquery tab. 

After entered an expression or a subquery, confirm editing by pressing the ENTER key. It will be added to the Diagram 

pane indicates that the statement contains an expression or a subquery and identifies the columns it is on. 

 

By clicking the  button, you will be switched to a subquery layer where you can build it visually in the same way as 

the main query. 

You can always go back to the main query by clicking (Main Query). 

View Generated SQL 

The SQL pane presents a read-only, formatted representation of the SQL generated by View Builder. You can copy the 

SQL that appears in the SQL pane for use in other tools. In a subquery layer, you can enable Show Current Layer 

Only to show the subquery SQL. 

Code Snippets 

Code Snippets provide an easy way for you to insert reusable code into editor when writing statements or scripts. The 

Code Snippet pane is on the right side of the editor. 
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The library includes built-in and user-defined snippets. Choose a label from the drop-down list or enter a search string 

in the Search box to filter the list. If you want to show the available snippets according to your database type, you can 

control-click anywhere on the library and disable Show Snippets For Other Database Type. 

 

Built-in snippets are non-editable. A user-defined snippet can be edited by double-clicking it in the library. If you want to 

hide the built-in snippets, you can control-click anywhere on the library and disable Show Preset Snippets. 

Use Code Snippets 

There are two ways to insert a snippet into the editor. 

¶ You can start typing the name of a snippet in the editor. Smart code completion will pop up a list of suggestions 

for the word completion automatically. Select a snippet name from the list, the saved code will be inserted to 

the editor. 

 

¶ You can simply drag and drop a snippet from the library into the editor. 

After inserting the snippet with placeholders to the editor, you can easily navigate to them by clicking on one of the 

placeholders, and then using the TAB key and entering the information. 
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Create Code Snippets 

You can create your own code snippets and add them to the library. To create a code snippet, select your desired code 

in the editor, then control-click and select Create Snippet. 

Alternatively, click  in the Code Snippet pane. If you use this method, you must manually enter the code in the New 

Snippet window; code selected in the editor is not automatically added to the Code box. 

Hint: Code snippets (.nsnippet) are stored under the default path, e.g. ~/Library/Application Support/PremiumSoft 

CyberTech/Navicat CC/Common/Snippet. 

Option / Button Description 

Untitled text box Enter the name of the snippet that displays in the library and the code 

completion list. 

Database Type Choose the database server type of the snippet. 

Label Choose an existing label or enter a new label name for the snippet. 

Remarks Enter a description for the snippet that displays in the library. 

Code Enter the code. 
 

Add a placeholder by highlighting any words in the code and click this 

button. The placeholder will be highlighted in light green. 
 

Remove a placeholder by highlighting it in the code and click this button. 

Move / Copy Snippet To Project 

If you have logged in to Navicat Cloud or On-Prem Server, you can synchronize the custom snippet in My Connections 

to a project. 

1. Control-click a snippet and select Move Snippet To or Copy Snippet To. 

2. Select an existing project. 

3. The snippet will be moved or copied to the project. 

Hint: You can move / copy a snippet in a project to My Connections in a similar way. 

Create Function / Procedure 

The essential steps to create a function/procedure are: 

1. On the Model tab, select Functions in the Model pane. 

2. Click . 
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3. Function Wizard will pop up and it allows you to create a function/procedure easily. 

4. Click Finish. 

5. A tab will open for you to edit the function/procedure. 

Create Collection 

The essential steps to create a collection are: 

1. On the Model tab, select Collections in the Model pane. 

2. Click , or click the down arrow and choose the collection type. 

3. Enter the name of the collection. 

4. Click OK. 

5. A tab will open for you to edit the collection. 

Add Embedded Document 

1. Click . 

2. Enter the name of the field and select object data type. 

3. Click the arrow icon left to the field name. 

4. Click  and define the item. 

Add Embedded Array of Documents 

1. Click . 

2. Enter the name of the field and select object data type. 

3. Enable Is Array. 

4. Click the arrow icon left to the field name. 

5. Click  and define the item. 

Add Predefined Object 

1. Click . 

2. Enter the name of the field and select (Predefined Object) data type. 

3. Choose the predefined object. 
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Create Predefined Object 

A predefined object refers to a specific document structure that is predefined or preconfigured. It is a predetermined 

schema or template that defines the fields and their data types within a MongoDB document. You can use predefined 

objects in any collection in the model to help maintain data integrity and establish consistent document structures. 

The essential steps to create a predefined object are: 

1. On the Model tab, select Predefined Object in the Model pane. 

2. Click . 

3. Enter the name of the predefined object. 

4. Click OK. 

5. A tab will open for you to edit the predefined object. 

Create MongoDB View 

Create View 

The essential steps to create a view are: 

1. On the Model tab, select Views in the Model pane. 

2. Click . 

3. Enter the name of the view. 

4. Click OK. 

5. A tab will open for you to edit the view. 

Pipeline Builder 

Pipeline Builder allows you to build a simple aggregation pipeline by defining stage operators. It consists of the 

following sections: Pipeline, Stage Editor. 
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 Pipeline 

A diagram to illustrate the aggregation pipeline. You can see all stages at a glance and add, delete, and move them as 

needed. 

 Stage Editor 

The Stage Editor is where you edit the selected stage. 

Choose Source Collection 

The source input of the pipeline is a single collection or view. Select Source in the pipeline and choose the Source 

Collection. 

Work with Aggregation Pipeline Stage 

You can break down a complex view into easier stages. In each stage, you complete a different operation on the data, 

such as filtering, grouping, sorting, and transforming. There is no limit to the number of stages used in the view, or how 

you combine them. 

Add Stage 

1. Hover over an arrow. 

2. Click the  icon. 

Move Stage 

1. Hover over a stage. 

2. Click and hold the  icon. 

3. Move it to the desired location. 



 40 

 

Enable / Disable Stage 

1. Hover over a stage. 

2. Turn on or off the stage. 

Delete Stage 

1. Control-click a stage and select Delete. 

Modify Pipeline Settings 

You can click Option to view and change pipeline settings. 

Create Entity 

The essential steps to create an entity are: 

1. On the Model tab, select Entities in the Model pane. 

2. Click . 

3. Enter the name of the entity. 

4. Click OK. 

5. A tab will open for you to edit the entity if your model is a logical model. 
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Chapter 6 - Diagram 

About Diagram 

A diagram is a visual representation of the relationships and structure of a data model. It depicts the tables, fields, 

collections, entities, attributes, and relationships between them in a clear and concise manner. You can use it in 

database design and development processes to communicate and document the logical organization of data within 

your system. 

 

 Object Pane 

The Object pane displays a list of all objects used in the diagram. 

 Toolbar 

The Toolbar is located near the top of the diagram. The buttons display in the toolbar depend on the model type 

(physical, logical and conceptual) and server type. You can use the toolbar to perform some basic tasks, such as 

adding tables, views, functions, collections or entities, applying Auto Layout feature, etc. 

 Canvas 

You can design your diagram on the Diagram Canvas. All added objects can be moved (by dragging them with mouse 

or by keyboard), resized, aligned to the grid, etc. 

 Properties Pane 

The  Properties tab includes the basic layout settings, object settings and so on. The properties vary with the type 

of the object selected. 

The  DDL tab shows the DDL of the selected object. 

 Overview Pane 

The Overview pane displays the whole active diagram in the canvas. To zoom in or zoom out the selected area of the 

diagram, adjust the slider. Same effect can be achieved with keyboard shortcuts: 














































































































